How Do I Arrange These Scripts? (Solved)


#1


So I downloaded some scripts. Some weren’t actively working (like the one that shows the correct answer right below the input bar, “Fast Abridged”) so I rearranged them, then things got even worse because now the audio plays twice or even trips multiple times and it’s so disturbing. Plus, the fast abridged still didn’t work :sweat:. I think these scripts are pretty cool so I wanna keep all of 'em and make this work somehow. If you know stuff about scripts, then can you be my hero and tell me how to arrange these scripts efficiently? I don’t know if should tag the people who made these though… Don’t wanna be annoying.

UPDATE: Fixed! Problem due to WaniKani Companion extension setting!


#2

The Fast Abridged script has been misbehaving recently.

@DaisukeJigen Did you fix this issue already?


#3

eh?:thinking:


#4

I remember people saying it wasn’t working


#5

hmmm. news to me. let me go back and look see my notification history. Maybe I missed something?

If its something more than settings link not appearing in menu, or not being able to add synonyms, I’m unaware of it. (those two have been fixed though)


#6

Maybe I’m just misremembering then


#7

Probably not. Sounds like there’s something wrong.

@noonmoontea Doesn’t work how? If you open the dev console F12, and go to Console tab, are there any error messages when it ‘doesn’t work’?


#8

I’ve never seen this script work since I installed it. Could be a myth for all I know :sweat_smile:.
Error Message:
image


#9

@DaisukeJigen,
What’s the markdown you used around F12?


#10

kbd
:keyboard:


#11

I just noticed that I can adjust the settings through the menu! I don’t know if it will change anything but I have reviews in 44 min so :crossed_fingers:


#12

Knew it wouldn’t be something easy :confused:
Can you try/have you tried only having open framework and fast abridged turned on? Possible my script and another are stepping on each others toes…
Another thing to try, open the settings for the script, and then save them. I doubt this has anything to do with it, as its suppose to default everything, but it’s worth a shot.
I don’t call ‘offset’ anywhere myself, which is what makes this a bit of guesswork. I do something that relies on other javascript that itself calls offset.

I can also use incognito mode to simulate a fresh install. See if it’s a brand new install issue. Won’t be til late tonight that I can do that though.
Edit: that didn’t work out like expected. Forgot incognito caries over all the installed scripts.

Update: Did notice, and fix, some settings related issues. Don’t think it would have caused the above issues though…


#13

Fast Abridged is working! Forgot to turn on my audio so there’s a chance that the creepy tripping still happens but in another 54 min I’ll find out. Now I’m afraid to rearrange the order for your script… feel like I hit somewhere close to home. Thanks for all your help :heart:!


#14

Not sure what I did to fix it, but good to hear.
Order really shouldn’t matter, other than Open Framework being first. If order does play a part, it would just change which script breaks. Scripts should be fully independent of each other and ordering (again, minus OF). If there is a ‘stepping on each others toes’ issue, order is unlikely to solve anything. If it does, its luck.


#15

In case you didn’t know: If you quote a post (using the Quote Whole Post button) you can see the markdown

image


#16

UPDATE: Okay I figured out the problem! It was the WaniKani Companion extension! The tripping stopped happening once I adjusted the setting for the info panel to automatically open during sessions. Plus, I got rid of that override one too (don’t think my pride will let me use it anyway) so all is well! Thanks for all your help guys!