[Client App] WaniKani for Android


#141

Hello,

recently I am having problems to log into my WaniKani account when using the app or when I try to access the website via mobile browser. . I am 100% sure that the login details are correct since it works fine with the website on PC. I did write an email to the WK support but they referred me to this thread. I don’t know what causing the login issue, just wondering if anyone has come across the same problem.


#142

Try contact the developers here:
https://play.google.com/store/apps/details?id=tr.xip.wanikani
https://github.com/xiprox/WaniKani-for-Android

By the way, I am still using this app, and it works OK.


#143

when i want to do a review on the go i have to log in, even though i have put in my API, i dont know what is going on, but i would want this issue to be fixed, because i can log in with the same username and password, on the computer, but when i use it in the app, it says that my username and password and invalid, and i dont even know what that is about…i want to know why i cant review on the app when i have already put in my api.
it seems to take me to a browser like page on the app, where i have to log in, but i cant log in despite my username and password being absolutely correct.


#144

This a third party developed app.  The developers of this web site did not produce the app.  

As explained by Viet in the Bugs List thread, something was done to the site on 29 November 2016:

viet said…^ Nothing was done to the API. Any changes to the API are versioned, and thus shouldn’t break the scripts…

Some minor changes to the javascript for both lessons and reviews were made.  The site’s jQuery dependency was just updated to latest (we were four versions behind); there were a few deprecations we had to address and it (our changes or the scripts dependency on our loaded jQuery) may have caused the scripts to break.

You’ll need to contact the script authors since we don’t officially support the scripts.
WaniKani is not responsible for the Android app.  I have gone to the developer’s web page and reported the issue.  I do not know if they are monitoring that page frequently.  

There is also an email address on the Google Play page for this app.  Has anyone tried to email them already?



#145

Hello, I replied about this to a user (@mizti?) over email yesterday and they managed to solve their issue. The following is a slightly trimmed version of what I wrote:

The main app works over your API key, whereas the reviews and lessons screens work with a browser implementation. This is required because the API wanikani.com provides doesn’t include reviews and lessons. So we just take you to a slightly customized mobile web browser for reviews and lessons. And in that browser, you get to log in again.

As for your issue, I would suggest these:
1. Your keyboard doesn’t insert some unwanted characters, right? Such as extra spaces or language-specific letters that weren’t used in you original password. I’d suggest you double check you email/username too.
2. Can you try changing your password on the website and trying your luck again?
3. Can you try clearing the data for the app in Settings?

Once again, the reviews and lessons screen are nothing more than a web browser taking you to wanikani.com as far as authentication goes. If there is something wrong, I highly doubt it’s something to do with the app itself. I suggest you try the above suggestions and get back if things don’t work.

Also, if you have further questions, it could be a better idea to just shoot me an email to x.ihsan@gmail.com instead as I see that almost instantly.

#146

Thank you. 
I cleared the app data (via settings).  That didn’t work.  
I reset the password.  That didn’t work.
I also unchecked the “HW Acceleration” box because I was getting desperate.
I noticed a space at the end of my username.  I deleted it.  That worked.


So the issue was with the WaniKani site after all.  It was working until about 29 November 2016.  I can only think that the username is not being trimmed of leading / trailing spaces.


#147

OMG thank you,

I’ve been having the exact same problem for the past few days.

Just removed a space from my username… worked haha


#148
ddumanog88 said... OMG thank you,

I've been having the exact same problem for the past few days.

Just removed a space from my username.. worked haha
 How do you change username, anyways? Email the admin? I want to hide my real name.

#149
patarapolw said...
ddumanog88 said... OMG thank you,

I've been having the exact same problem for the past few days.

Just removed a space from my username.. worked haha
 How do you change username, anyways? Email the admin? I want to hide my real name.
 yes shoot them (hello@wanikani) email about username change~ some member already success changed their username~ me probably want change too in future~

#150

@patarapolw:  we are not talking about a change of username here.  Without my knowledge, the mobile phone was adding a space character to the end of my username.  I could not login via the app because it kept saying my username / password were incorrect.  I had to backspace over the space character to delete it.  This solved the problem.


#151

Thanks so much for posting a solution to this problem. It was driving me mad! I never noticed the extra space after the username.


#152

Does anybody else have issues with the reading sounds getting played? I’ve tried everything I could think of over the last few months (toggled the mute button, put all my volume settings to max, made sure the phone isn’t in silent mode, …) but still - nothing. Is there some hidden setting somewhere?
I’m using a Samsung Galaxy S7 edge and the old app played sounds just fine on that device. Other apps don’t have sound issues, either. Am I missing something?


#153

Hello,

Just pushed a new update (after 15 months ;_:wink: which fixes plenty of stuff (huge thanks to contributors!) including battery drain, memory issues, crashes, visual problems, and more.

As I wrote on GitHub too, at this point I’m “officially” no longer actively working on this app. This means that no new features will be added and probably nothing big will change. However, I will be doing fixes and making sure things work nicely. This is kind of an improvement over last year which was me being completely dead when it came to this app, as sad as that sounds.

This update may sound like a “final” release but that’s not really it. I just wanted to get all the changes that were piled up in the codebase out there and put the app back on the tracks. From here on I’ll focus on fixing bugs.

Good luck with your studies and Happy New Year! 


#154
Satsuko said... Does anybody else have issues with the reading sounds getting played? 
 Yes. This is a bug reported by multiple users. I tried to reproduce it but couldn't. While I couldn't make it in time for this update, it's at the top of my priority for the next.

#155

Good to know! Thanks for keeping this app updated even if it will only be for fixing bugs.
Is there anything we could do to help you with finding out what the issue is? If you can’t reproduce it it’s hard to investigate and fix it, isn’t it?


#156

Sorry


#157

There is never a sound for me. Always silent.


#158

hello dear developer〜

i want to report i cannot doing review〜 each inputing answer im cannot enter/proceed my answer〜
my device is plain google device with android 7.1.1〜 no root 〜

usually for mobile solution me using allicrab on my ios device but your andoid app is way more cuter and cleaner with material desing so im jump in〜



should you have free time、please check further investigation in latest nougat okay〜
cheers ♪


#159

Hey xip, I know you said there weren’t any new features coming but if it wouldn’t be a huge effort, could you maybe add an option to make the Kanji font bigger? It’s sometimes hard to read on my Pixel XL :frowning:


#160

Hello, @Naitimo. I’m afraid that would require plenty of changes to the app’s code. I’ll have to say no to that one.