Chrome rendering terrible compared to I.E


#1

SOLVED IT.  Disabling hardware acceleration in chrome sorted it! 



Hello, please help...


Not really an API question, so sorry if wrong place to post, but I figure the people that know about this stuff might be able to help.


My fonts (and some images) in chrome and firefox appear fuzzy/unclear compared with Internet Explorer. It makes it quite uncomfortable reading. This is not just wanikani, but any website. I am on windows 7 with latest browsers.
No matter how much I search the google I cannot find a solution.


I really want to use chrome as my browser and not IE, but at the moment it's just horrible to read.
(my mac doesn't have this problem, and neither does a few other computers I have access to at work)


A couple of screenshots to show you my pain >>IE on the left, Chrome on the right.
 Can you see the difference? What can be causing this horror?





#2

The first things I would try is to reinstall Chrome or Firefox to see if that can help.
The second thing is checking that your graphic card drivers are installed and up to date.

If that doesn’t work it’s time to start investigating.


#3

Yep, I have tried that. I only installed firefox because I thought it was a chrome issue. but turns out that's the same. Its not just the fonts either though. In office 365 web email the Skype logo looks really bad in chrome, but ok in IE.


I was wondering if it was a windows thing, but other programs don't seem to be affected. odd hey!




#4

What version of Chrome do you have?

Type chrome://version/ into a tab, the first line is the version.


#5
Google Chrome 50.0.2661.102 (Official Build) m (32-bit)

#6

I might try the 64 bit version…


#7

Is this any use? http://www.thewindowsclub.com/disable-font-smoothing-windows


#8

no that seems to make no change. 64 bit makes no difference either!

Looking at this kanji, it’s almost as if it cannot draw curves without them becoming pixelated. vertical and horizontal lines are ok.





#9

SOLVED IT.


Disabling hardware acceleration in chrome sorted it!


how bizare! thanks for your thoughts peeps


#10

SOLVED IT.


Disabling hardware acceleration in chrome sorted it!


how bizare! thanks for your thoughts peeps


#11

Having this problem as well, only seems to affect chrome and firefox. A fix would be fantastic since while English is bad, Japanese (and especially kanji) is borderline illegible. It seems to be a recent issue, maybe a Windows patch or something.

What version of Windows do you have? And how long have you had this issue? (I’m on Windows 10 and I’ve had the problem for a few days or so)


#12

Did you try turning the hardware acceleration off?

In chrome settings search for hardware, and untick ‘use hardware acceleration when availabe’. 
this worked for me.


#13

Well…

That box is already unticked for me. Unfortunate, It’s really weird though to have this pop up so suddenly.


#14
Dormic said...That box is already unticked for me. Unfortunate, It's really weird though to have this pop up so suddenly.
Just as an experiment:
In Chrome, go to chrome://flags, then search for DirectWrite, Disable it, and relaunch the browser.  If that doesn't make a difference, re-enable it.

If that *is* the problem, I'd recommend making sure your video driver is up to date... which does NOT mean Windows updates, because Microsoft has a tendency to downgrade video drivers for some irritating reason.  Go to your video card manufacturer's website, and get their latest driver.

I know the DirectWrite thing was an issue a few years ago, but I've seen it re-emerge within the last few months for some reason.  Disabling it shouldn't be considered a permanent solution, though, since that reduces performance a little.