Backspace key not working while adding user synonym during reviews

Just like the title says. While in the middle of a review session, I decided to add “to resist” as a user synonym for 耐える, but typed too quickly and ended up with “to ressit”. Went to backspace, and it doesn’t respond at all while hitting the key. The delete key works fine, so I just did that in the meantime, but figured I’d mention the weird quirk since I noticed it. I’ve not run into the issue before. Is anybody else noticing the issue?

Note: Backspace works fine when adding a user synonym from the actual kanji’s page. It seems to be specifically limited to when trying to add one during the review session.

If it makes a difference: I’m using Windows 10, Microsoft Edge, with no userscripts installed at all.

1 Like

Probably worth mentioning the @Mods

1 Like

Ah, yeah, probably so. I was mostly just curious if anybody else was seeing the issue before I bumped it up to them (make sure I’m not just missing something silly on my end).

Works for me on chrome

1 Like

I’ll try it again here in about 15 minutes when my next review pops up. Could be it’s limited to something in Edge being silly. At first I just thought my backspace key went out until I tested it in other things! :stuck_out_tongue:

Hm. I just tried it in Firefox, Chrome, and Microsoft Edge, and it’s still doing the same thing to me in all 3 browsers.

It’s as if it doesn’t recognize that I’m in the textbox, honestly, because (I just discovered) if I try to type “f,” it also just closes the dropdown entirely instead of the typing the letter.

The only other thing I can think of (given that it’s working for others), is maybe it’s an issue with the IME? I tend to keep my keyboard in the IME mode at all times, just bouncing between romaji/hiragana/katakana modes as needed. Though, when I switch to ENG keyboard, it still behaves the same, so it would seem to rule that out.

Ultimately, it seems like it’s on my end somewhere, though, so I’ll try and fiddle about with it, see if I can come up with a solution. If I do, I’ll post it here, in case somebody else runs into the issue, but if not, oh well! I’ll just live with it. It’s not very often I add synonyms, anyway.

Sorry to hear you’re experiencing this issue! I’ll let the team know and see if we can figure out what’s going on.

One thing that jumps out is that you’re using Microsoft Edge and it’s unfortunately not one of our supported browsers. Could you try it out on another browser and see if it’s working there?

1 Like

I tried it in both Firefox and Chrome 25 minutes ago, and it was doing the same thing to me (the reply directly above yours talks about it in more detail). @Gorbit99 mentioned it was working on his end in Chrome, however, so it’s likely some wonky behavior with the Microsoft IME.

I intentionally rolled the IME back to an older version since the newer version didn’t want to pop up the dictionary suggestions in spite of having that setting on (which I don’t use while studying WaniKani, but I do use literally everywhere else, so) a couple weeks ago, so I suspect it’s related to that more than anything, as all works work fine in my mobile browser (and seems to work fine in Chrome for others). I’ve also never experienced any issues using Edge until just barely (given that it’s chromium-based nowadays, basically anything that works in Chrome works in it now, anyways).

I’ve brought the IME back up to the newest version; when my next review pops up, I’ll test it again (in all browsers) and report back.

Thanks for responding!

(Just as an aside: This also shows me that the newer version of IME is showing the dictionary again, anyway, so yay for that!)

Well, that didn’t resolve it, either. I made sure I was running the newer version of the IME, and tried it out in Edge, Firefox, and Chrome. All 3 are doing the same thing; behaving as if it doesn’t fully recognize that I’m in the textbox. Backspace doesn’t do anything, and “F” closes the dropdown instead of getting typed in. (Other text still goes in though).

Ultimately, I’m not too bothered by it; it’s only once in a blue moon that I ever bother to add a user synonym instead of just making myself learn it as taught, and I can always go and add it through the individual kanji/vocabulary word’s page, anyway. Mildly curious what in my set-up is causing it, though; I’ll have to think on what the cause could be.

The other day I tried to add a synonym that had the letter “f” and it kept making the page jump around. It seemed like maybe the “F” key was tied to a keyboard shortcut during reviews and pressing it would activate the shortcut instead of typing into the synonym. It may be related.

I’ll try this again the next time I have reviews to see if it happens again.

1 Like

It’s certainly doing the same thing for me at the moment.

“F” is a keyboard shortcut during the reviews, for sure. It brings up/closes the item info box. What is abnormal is that if you are clicked into the text box, that should override any of the shortcuts, and it doesn’t seem to be doing so. At the very least, that’s one shared issue that isn’t just on my end, it seems.

It occurred to me that I have compatibility mode on and maybe that’s why it doesn’t happen to me?

1 Like

That could be; which OS are you running it in compatibility mode for so I may test it?

Edit: Never mind that; I misunderstood. Apologies. Putting Chrome into that mode, and when I have more reviews, I’ll try it out.

It’s not chrome, it’s wk.

1 Like

Ah, misunderstood twice over, then. That’s now been turned on; Chrome reverted back to default, and we shall see what happens in 15 or so minutes.

Where I don’t use scripts, though, I shouldn’t think that would need to be turned on. If it solves it, then I’ll leave it on, though. :man_shrugging:

Having it off you get the latest additions or changes to wanikani, that’s why it’s script compatibility mode, because then scripts can be updated without them not working for a while at all. If this is a new thing, it’s very likely inside compatibility mode, and that’s why I’m not seeing it.


Ah, yep! That resolved the issue. I can now use “F” in synonyms, and backspace key gives me no issues. That would mean that there was a recent change to WaniKani that caused it then, right?


Right now it is fixed for script compatibility mode too. I believe this has also happened before as generic changes were accidentally affecting script compatibility mode.

1 Like

Hi! If I’m understanding correctly, did you disable all of your scripts and enable script compatibility mode? Did that solve the issue for you?

1 Like


I don’t use any scripts to begin with, so I didn’t have to disable anything.

Enabling script compatibility mode did resolve the issue.

However, a while after enabling the compatibility mode, I decided to go back and test if turning it off would bring the issue back, and it hasn’t. Everything seems to be working perfectly fine whether it’s on or off now.