[Android] Smouldering Durtles (v1.0.7) - native app with offline lessons and reviews, plus themes and script-like features!

Did anyone get the Github APK to properly update via the Play Store? When SD came out, I installed the APK from Github and manually recreated all the settings I had in FD. Since the Play Store version was published, the Play Store app now recognizes SD to be installed, but doesn’t offer updates automatically. Only if I open the SD page in Play Store, the the green “Install” button becomes “Update”. When I press that, it attempts to download and install but returns an error message about not being able to update with some with generic suggestions.

I suspect the app is somehow not linked to the app store properly due to there never having been a proper play store install, but fear that if I uninstall and reinstall via the play store, I might lose all settings again (bothersome since there’s no export/import app settings option).

Any ideas?

I’m having trouble with my emulated version of SD. It’s working fine on my phone, but this morning, I updated my copy in Bluestacks5, and when I opened it, my dashboard had basically no data (0 lessons, 0 reviews, I can’t remember but my review forecast might have been blank, nothing in the jouyou kanji progress, and there were 8 background tasks that wouldn’t complete).

I tried restarting Bluestacks, flushing the background tasks, force stopping the app, and even uninstalling, but as soon as I put my API key back into the new install, it got 8 bg tasks, and has been stuck on “Please wait while we prepare the app for your account” for about two hours (while I used my phone to do my lessons).

This comes after a week or so of no audio available in lessons, despite all my settings being set to autoplay it, but this is clearly a bigger issue. My actual phone version seems to work just fine, so I’m not completely locked out, but something’s gone haywire on my emulated version.

Any suggestions? Thanks!

I did not know you could get the play store to update apps you installed through other means. I would be nice, but it might also just be impossible. In that case you would have to uninstall, and then reinstall through the playstore.

I did a quick google search because I was curious, and my conclusion is that it is indeed only possible to update apps installed trough the playstore itself.

1 Like

Hi all. I keep having problems with Smoldering Durtles and notifications. In 1.0.4 I needed to turn them on in the Android app settings, and for 1.0.5 I can’t turn them on at all. Android says this app doesn’t send notifications…

1 Like

1.0.5 is showing notifications on both my Android 10 test device and in the Android 13 emulator without issue.

What OS version are you running?

Apache 2.0 is (at least according to the FSF) compatible with GPL 3 but not with GPL 2. (The difference is because the Apache 2 license has some wording in it about patent licensing.) So you were at least 50% right :slight_smile:

I’m afraid I’ve not got any experience with Bluestacks as I’m on macOS - have you tried using the emulation built into Android Studio as a point of comparison, for example?

I’m afraid that emulation is a bit of a niche use-case and there’s only so much testing I can do to ensure compatibility with stuff like that.


I just can’t imagine the undertaking you just did with this @joeni It’s just really big from you and I wanted to say so properly!

(I don’t use it, but I do make it known how great this is, that you made a new version of this app, so many Wanikanians use! :slight_smile:

1 Like

I’m having the same issue, running a Pixel 7 on Android 13 with the latest May security update. App is 1.0.5

1 Like

It doesn’t either on my phone, Android 13

1 Like

It was on the roadmap to look at and your issue prompted me and so I’m literally working on that right now.

As it stands I have working backup for settings, but it’s bugging out on saving the colour preferences, I suspect I’ll get it working soon however :+1:

I believe I’ve resolve the permission request issue, I think I may have inadvertently overwritten my own changes to comply with Android 13’s new requirement for explicit permission for alarm setting when I merged some bits in, so I’ve had to fix it again.

Just need to test it and I can push it out :slight_smile:


Dude, you responding so quickly to these requests makes me feel bad :sweat_smile: Don’t burn yourself out.


It’s latest Android 13 for Pixel 6.

1 Like

Will have an update pushed out with a fix this morning, I hope :+1:t3:

1 Like

It’s okay, I’ve got a lot of time at the moment as I’m away, but after knocking my head against it for a while and how to handle all the various settings item types gracefully, I’ve got a working method that will let you save all current settings (including theme customisation) as a .json file.

Just did a complete app uninstall, reinstalled, restored the json and all the settings are working as expected! This doesn’t help if you’ve got an older version, but it will reduce pain for people who want to install a dev version and then go back to store version, or change between phones, etc.



Just to say that I’ve found the cause of the audio button not showing for kana vocab - the button trigger was tied to there being a reading question linked to the subject.

Current trying to create a case for it to show regardless if it’s kana vocab, but the audioutil is ALSO tied to readings as part of the voice selector preference and it’s proving a tricky, I should get it done soon though :+1:t3:

1 Like


60% me, 40% GPT4, but got it in the end. Genuinely thankful you, our AI overlords, for letting me, who didn’t touch Java till I took on this project, be able to fix things ^^

GPT3.5 can do one though, the most agonising time is when my GPT4 ‘25 prompts her 3hrs’ times out and I have to wait out, because I know if I rely on GPT3.5 it’ll ruin the code and I’ll have to go back to square one, haha

Going to live-device test and then push the update out ASAP, will fix the notification issue, the audio issue, and impliment the backup method. Still on the docket to fix is the SRS toast not appearing for kana, but there’s only so long I can put off pushing the notification fix, so I’m capping progress at this point and will do the rest in another update.




Bug Fixin’ :space_invader:

Am happy to tell @TsubasaJM, @jfn4th, @whinette that notifications should now be working on Android 13 again once you turn them back on via the App Info page (or settings) - please do let me know if you notice any other issues with them!

Am likewise happy to tell @Slysoft that the gradients for both the light theme and Nord are now the right way round… though I’m afraid that one of the squares insists on being a pain, due to a messed up hex code I didn’t notice, it’ll be fixed in the next update :sweat_smile:

Am pleased to tell @mtlvmpr that there’s now play buttons on the kana vocab item pages (once the audio is downloaded, of course) - thank you for your continued diligent issue reporting!

New Backup/Restore Feature

Thanks to @VannHarl’s plight drawing my attention to it, I’ve added a backup and restore option now! This will back up your settings as a .json file, allowing you to migrate them between devices or safely uninstall without losing all your tweaks! The settings can be accessed even while the first-run API pull is occurring, so you don’t have to wait until everything is downloaded to get it how you like it!

What is backed up?

Basically anything you do via the Settings menu, from custom theme colours, to advanced review batch config and search engines. It should even remember if the Advanced Sections section is toggled on.

What isn’t backed up?

Your API key and website password (if you’ve entered that).

You’ll find these options below the reset options:


Just in case you didn’t know, Bing Chat in Creative mode also uses GPT-4, is free, and has a much higher limit of a few hundred messages per day (which also keeps getting higher). It does have an individual conversation limit of around 20 messages but you can get a lot done in that many and personally I rarely run up to the limit even with fairly complex programming things as it’s perfectly happy to write very long answers or answer a couple of questions in one reply. It is unfortunately missing ChatGPT’s plugins currently but that’s apparently coming soon!

1 Like

Awesome! This is a big help! Getting the colors back to what they were before was particularly tricky due to the sliders being less than exact. This should take care of that :heart_eyes: