[Android] Flaming Durtles - Android app with offline support

You could try typing hyphen (-)

1 Like

I feel so dumb rn. It worked, thank you!

1 Like

Hi! I’ve noticed that the app is starting to teach me level 4 radicals and kanji even though there seems to be vocabulary left from level 3. I suspect I might have changed something when I discovered the advanced settings. I wanted to enable the special buttons since I made many typos due to I and O being so close together…

Does anyone have an idea how to force the app to complete the lower level vocabulary?


This is normal WaniKani behavior and is by design.

In the “lesson advanced settings”, set the “order” to “level, type” or “level, then shuffle”. I think that should put the lower-level vocabulary before the higher-level radicals and kanji.


That did it. Many thanks!

1 Like

Recently I’ve noticed 4 of my reviews not syncing up with the app. I didn’t know if there is a reason for that or if its a glitch. Ive tried manually syncing but they dont show up. The ones that aren’t syncing are 外れ and 外れる 公用 作用.

1 Like

This happens because the items in question have been moved to a different level after you have done the lessons for them in the app. The app assumes anything that is not from your current level is not meant to be reviewed yet, even if you have already done the lesson for them.

1 Like

How do I fix it? :thinking:

Couldn’t find a fix myself. I occasionally log in to the website to do any outstanding reviews that aren’t in the app. In my case that’s only ever 1 item. In your case, it’s 4.


That came up several times in this thread now. The usual fix is to reset the database through the settings in the app.

1 Like

I tried that multiple times. Didn’t work for me.

For me it worked but had to do it everytime items were shuffled.

1 Like

Did you give completely purging and reinstalling the app a try? Remove cache and data in the Android settings and then remove and re-install the app.

1 Like

Honestly, I did not do that. And given the amount of customization I have done in the app (customized all the colors in the bars using sliders - if you haven’t done that, I’d urge you not to. I wasted perhaps half an hour extracting colors from the WK website and trying to get them into the app by fiddling with sliders with my fingers), I’m really not inclined to try it. But if it works, at least that would be another avenue for someone to try :grin:.

1 Like

Hi, I was attempting to use the app again after a year off from Wanikani, however when I entered my v2 API key the screen just refreshed to show me the “enter API key” screen every time.

Device: Google Pixel 6 Android 13

I expired my existing keys and generated a new one, tried force stopping and restarting the app, uninstalling and reinstalling, but all roads (and literally all app options including stuff like “About”) just refresh the app into the initial “Enter V2 API Token” page.

Any ideas? Thanks in advance!

I was hitting the same problem. Tried resetting the database and that didn’t change anything. Reluctantly tried fully resetting the app - stopped the app, cleared the cache, cleared all the data, uninstalled, reinstalled. Still have a 3 review discrepancy between WK and Flaming Durtles. I use Durtles for almost all of my reviews, but for the foreseeable future I will be getting on WK periodically just to clear those stragglers.


Unfortunately that hasn’t worked for me :frowning:

I guess next step is to make a GitHub issue

I have the same issue, with at least one of the same Kanji. I just installed Flaming Durtles for the first time and noticed there was 1 less review on Flaming Durtles than on the web, and it showed three fewer burned items. The one item that was available for review on the web but not in the app is 外れる, and I didn’t confirm but I can assume the three items that are burned on the web but not showing in the app are the other three that Sara718 isn’t getting in their app reviews.

1 Like

I haven’t tried a full reset either but in I checked that the “next review” date is correct in flaming durtles, so clearly it knows that the item is up for reviewing but it will ignore it if the entry is for a level I haven’t reached.

So I just log into the website from time to time as well in order to do the couple of “stuck” reviews.

Quick question: what’s the deal with the green arrows and a number that appear on top of the upcoming reviews? Do they mean something?

1 Like